Fiber between Spokane and Seattle has been repaired.
Update
Update
We've moved traffic from our primary upstream provider to our secondary, to reduce latency and keep connections more stable. We have not received an ETA from the primary provider.
Monitoring
Monitoring
Fiber between Spokane and Seattle is experiencing degradation. Our path has failed over to re-route through Missoula MT in the mean time.