Scheduled for August 13, 2025 at 5:00 PM – 8:00 PM
Affects
Network Monitors
Under maintenance from 5:00 PM to 8:00 PM
Chattaroy, WA
Under maintenance from 5:00 PM to 8:00 PM
CHATWALM
Under maintenance from 5:00 PM to 8:00 PM
Updates
Completed
August 13, 2025 at 8:00 PM
Completed
August 13, 2025 at 8:00 PM
Maintenance has completed successfully
In progress
August 13, 2025 at 5:00 PM
In progress
August 13, 2025 at 5:00 PM
Maintenance is now in progress
Planned
August 13, 2025 at 5:00 PM
Planned
August 13, 2025 at 5:00 PM
Emergency Maintenance Notice
Date: Today, August 13th 2025
Time: 10:00 AM – 12:00 PM PST
We will be performing emergency maintenance on our Chattaroy tower to replace a failing piece of equipment. This work is necessary to prevent a larger service disruption, and unfortunately, it cannot be completed after hours due to safety considerations.
During this time, internet service for some Chattaroy, WA customers will be unavailable. We appreciate your understanding and patience while we complete these urgent repairs.